
Unit I 

### **Introduction to Power BI** 

 

**Power BI** is a business analytics tool developed by Microsoft that allows users to 

transform raw data into interactive dashboards and Business Intelligence reports. It connects 

to a wide variety of data sources, performs data transformation, and provides powerful 

visualization tools to create insightful reports and share them within an organization. 

 

### **1. Getting Started with Power BI** 

Power BI consists of several components: 

 

- **Power BI Desktop**: A Windows application for data transformation, modeling, and 

creating reports. 

- **Power BI Service**: An online SaaS service for sharing and publishing reports. 

- **Power BI Mobile**: Mobile apps for viewing and interacting with reports on the go. 

 

### **2. Overview: Power BI Concepts** 

 

1. **Dataset**: A collection of data that you import or connect to. It could be an Excel file, a 

SQL database, a cloud-based service, etc. 

2. **Report**: A multi-page visual representation of your data. Each report can contain 

multiple pages with various visualizations. 

3. **Dashboard**: A single-page view that consolidates visuals from one or more reports. 

4. **Visualization**: The graphical representation of your data, like charts, graphs, maps, 

etc. 

5. **Tile**: A single visualization in a dashboard. 

6. **Workspace**: A shared environment in the Power BI service where you collaborate 

with your team. 

 

### **3. Sign Up for Power BI** 

1. **Go to the Power BI website**: [Power BI](https://powerbi.microsoft.com/) 

2. **Click "Try Free"** and follow the prompts to create an account. 

3. Use a business email address to sign up. Personal email addresses (like Gmail) are not 

supported. 

 

### **4. Overview: Power BI Data Sources** 

Power BI supports a variety of data sources, such as: 

 

- **File-based**: Excel, CSV, XML, JSON, PDF, etc. 

- **Databases**: SQL Server, MySQL, Oracle, PostgreSQL, etc. 

- **Online Services**: SharePoint, Salesforce, Google Analytics, Azure, etc. 

- **Cloud-based SaaS Solutions**: Dynamics 365, Azure, etc. 

 



### **5. Connect to a SaaS Solution** 

1. Go to **Power BI Service**. 

2. Click on **Get Data**. 

3. Choose **Services**. 

4. Search for the desired SaaS solution (e.g., Dynamics 365, Salesforce). 

5. Provide your credentials to connect to the service and import data. 

 

### **6. Upload a Local CSV File** 

1. Open **Power BI Desktop**. 

2. Click on **Home** > **Get Data** > **Text/CSV**. 

3. Browse and select the CSV file from your local system. 

4. Click on **Load** to import the data into Power BI. 

 

### **7. Connect to Excel Data that Can Be Refreshed** 

1. Go to **Power BI Desktop**. 

2. Select **Get Data** > **Excel**. 

3. Choose an Excel file with data tables. 

4. Click on **Load**. 

5. After loading, set up a **gateway** to refresh data automatically in the Power BI service. 

 

### **8. Connect to a Sample Dataset** 

Power BI provides built-in sample datasets for testing and learning. 

 

1. Go to **Power BI Service**. 

2. Click on **Get Data**. 

3. Select **Samples** and choose a sample dataset. 

4. Load the dataset and start creating visualizations. 

 

### **9. Create a Report with Visualizations** 

1. Open **Power BI Desktop**. 

2. Import data from any data source. 

3. Go to the **Report** view. 

4. Drag and drop fields onto the canvas to create visualizations. 

5. Use different types of visuals like charts, tables, and maps. 

 

### **10. Explore the Power BI Portal** 

1. Sign in to the **Power BI Service**. 

2. Navigate through **Workspaces**, **Reports**, **Dashboards**, and **Datasets**. 

3. Explore different dashboards and interact with visualizations. 

 

### **11. Overview: Visualizations in Power BI** 

Visualizations are key to representing data insights. Power BI offers many visualization 

options, such as: 

 



- **Charts**: Column, Bar, Line, Area, Pie, Donut, etc. 

- **Tables and Matrices**. 

- **Maps**: Filled Map, Shape Map, ArcGIS Maps, etc. 

- **Cards**: Single Value, Multi-row. 

- **Gauge**: Displays a single value. 

- **Text**: Titles, Labels, Tooltips. 

 

### **12. Using Visualizations to Create a New Report** 

1. Import your dataset. 

2. Go to the **Report** view. 

3. Drag fields to the canvas to create visualizations. 

4. Apply filters, slicers, and drill-downs. 

 

### **13. Create and Arrange Visualizations** 

1. Select the type of visual you want from the **Visualizations** pane (e.g., Column Chart). 

2. Drag fields to the **Values**, **Axis**, or **Legend** sections. 

3. Resize and position the visuals as needed. 

4. Use **Formatting** options to customize colors, labels, and titles. 

 

### **14. Format a Visualization** 

1. Select the visual on the canvas. 

2. Click on the **Format** pane (paint roller icon). 

3. Modify properties like colors, data labels, background, borders, etc. 

 

### **15. Create Chart Visualizations** 

Power BI supports a variety of charts: 

 

- **Column and Bar Charts**: Represent data vertically or horizontally. 

- **Line Charts**: Used to show trends over time. 

- **Pie and Donut Charts**: Show proportions of a whole. 

- **Area Charts**: Display cumulative data. 

 

#### Example: 

1. Import a dataset with sales data. 

2. Select a **Column Chart**. 

3. Drag `Sales` to **Values** and `Month` to **Axis**. 

 

### **16. Use Text, Map, and Gauge Visualizations and Save a Report** 

1. **Text Visual**:  

   - Use a **Card** visualization to show a single value. 

   - Drag a field (e.g., `Total Sales`) onto a card. 

 

2. **Map Visual**: 

   - Select a **Map** visual. 



   - Drag `Country` to **Location** and `Sales` to **Size**. 

 

3. **Gauge Visual**: 

   - Use a **Gauge** visual to show a KPI. 

   - Drag `Sales` to **Value**, and set `Min` and `Max` targets. 

 

### **Saving the Report** 

1. After creating your visualizations, click on **File**. 

2. Select **Save As** and choose a location to save your `.pbix` file. 

3. In Power BI Service, click on **Save** after creating the report. 

 

Power BI is a powerful tool that allows you to import data from multiple sources, create 

interactive reports, and share them within your organization. By using different visualizations 

and features, you can uncover deeper insights from your data. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

UNIT II 
### **Power BI: Working with Reports and Dashboards** 

 

**Reports** and **Dashboards** are two key components of Power BI. Reports are multi-

page interactive visuals, whereas dashboards are a consolidated, single-page overview of key 

data points. Below, I’ll walk through various operations you can perform with reports and 

dashboards, including modifications, sharing, and management. 

 

### **1. Modify and Print a Report** 

 

#### **Modify a Report** 

1. Open **Power BI Desktop** or the **Power BI Service**. 

2. Go to the **Report** view. 

3. Select any visual on the page and edit fields, apply filters, change formatting, or add new 

visuals. 

4. Add new visuals by dragging fields from the **Fields** pane into the canvas. 

 

#### **Print a Report Page** 

1. Open the report in the **Power BI Service**. 

2. Click on the **File** menu. 

3. Select **Print this page**. 

4. Choose your printing options and click **Print**. 

 

> Note: You can also export the report to a PDF format if you prefer to distribute it digitally. 

 

 

### **2. Rename and Delete Report Pages** 

 

#### **Rename a Report Page** 

1. In the **Power BI Desktop** or **Power BI Service**, go to the bottom of the canvas 

where the page tabs are listed. 

2. Right-click the tab of the page you want to rename. 

3. Select **Rename** and enter the new name. 

 

#### **Delete a Report Page** 

1. Right-click on the report page tab. 

2. Select **Delete**. 

3. Confirm deletion if prompted. 

 

 

### **3. Add a Filter to a Page or Report** 

 



#### **Types of Filters in Power BI** 

1. **Page Filters**: Apply to a single page in the report. 

2. **Report Filters**: Apply to the entire report. 

3. **Visual Filters**: Apply to a specific visual. 

 

#### **Add a Filter to a Page or Report** 

1. Open the report in **Power BI Desktop**. 

2. Go to the **Filters** pane on the right. 

3. Drag a field from the **Fields** pane into the **Filters** pane. 

4. Choose whether to apply the filter to the **Visual**, **Page**, or **Report**. 

5. Adjust filter options as needed (e.g., select specific values or set a range). 

 

 

### **4. Set Visualization Interactions** 

 

Visualization interactions control how different visuals respond to each other in a report. 

 

1. Select a visual to activate the **Format** pane. 

2. Click on **Edit Interactions** from the **Format** tab. 

3. Choose how the other visuals on the page interact: 

   - **Filter**: The visual filters other visuals. 

   - **Highlight**: The visual highlights related data points in other visuals. 

   - **None**: No interaction. 

 

This allows you to customize how one visual's selection impacts others in your report. 

 

 

### **5. Send a Report to PowerPoint** 

 

1. Open the report in the **Power BI Service**. 

2. Go to the **File** menu. 

3. Select **Export to PowerPoint**. 

4. Choose your export options (current view, entire report, etc.). 

5. Click **Export** and download the resulting `.pptx` file. 

 

> This process converts each page of your report into a PowerPoint slide, making it easy to 

share in presentations. 

 

 

### **6. Create a Dashboard** 

 

Dashboards in Power BI are single-page collections of visuals, tiles, and KPIs from one or 

more reports. 

 



1. Open a report in the **Power BI Service**. 

2. Click on a visual you want to add to a dashboard. 

3. Select **Pin visual** from the menu above. 

4. Choose whether to add it to an **existing dashboard** or **create a new dashboard**. 

5. Give your dashboard a name and click **Pin**. 

 

#### **Adding More Tiles to the Dashboard** 

- You can also add text boxes, images, and web content to dashboards by clicking on the 

**Add tile** option in the dashboard view. 

 

 

### **7. Create and Manage Dashboards** 

 

#### **Edit a Dashboard** 

1. Go to your dashboard in the **Power BI Service**. 

2. Click on the **Edit** button. 

3. Rearrange tiles, resize, or delete them as needed. 

4. Use the **Format** pane to change tile properties, like borders and background color. 

 

#### **Delete a Dashboard** 

1. Go to the dashboard. 

2. Click on the **More options** (three dots) next to the dashboard name. 

3. Select **Delete** and confirm. 

 

 

### **8. Publishing Workbooks and Workspaces** 

 

A **workspace** in Power BI is a shared environment for collaboration on reports, 

dashboards, and datasets. 

 

1. Open **Power BI Desktop** and build your report. 

2. Click on **Publish** in the top menu. 

3. Choose the destination **workspace** (e.g., *My Workspace* or a shared workspace). 

4. Click **Select** to upload the report to the Power BI Service. 

 

#### **Create a Workspace in Power BI Service** 

1. Go to the **Workspaces** section in Power BI Service. 

2. Click **Create a workspace**. 

3. Provide a name, description, and permissions. 

4. Click **Save**. 

 

### **9. Share Data with Colleagues and Others** 

 

1. Open the report or dashboard in the **Power BI Service**. 



2. Click on the **Share** button. 

3. Enter the email addresses of the people you want to share with. 

4. Choose their permission level: 

   - **View** only. 

   - **Edit** (for co-ownership). 

5. Add an optional message and click **Share**. 

 

> Shared users will receive an email notification with a link to the report or dashboard. 

 

 

### **10. Publish a Report to the Web** 

 

1. Open the report in the **Power BI Service**. 

2. Go to the **File** menu. 

3. Select **Publish to web**. 

4. Power BI will generate an **embed code** and a **public link**. 

5. Copy the link to share or embed the report in a webpage. 

 

> **Caution**: Reports published to the web are publicly accessible, so use this option 

carefully. 

 

--- 

 

### **11. Manage Published Reports** 

 

1. Go to the **Power BI Service**. 

2. Open the **Settings** menu. 

3. Select **Manage permissions**. 

4. Control who has access to the report, update settings, or delete the published report. 

 

--- 

 

### **12. Share a Dashboard** 

 

1. Go to the dashboard you want to share. 

2. Click the **Share** button. 

3. Enter the recipients’ email addresses. 

4. Set their permission levels (view or edit). 

5. Click **Share**. 

 

> You can also manage permissions from the **Manage Permissions** menu on the 

dashboard. 

 

--- 



 

### **13. Create an App Workspace and Add Users** 

 

1. In the **Power BI Service**, click on **Workspaces** > **Create a workspace**. 

2. Name your workspace and set permissions. 

3. Add users and assign roles (Admin, Member, Contributor, or Viewer). 

4. Click **Save**. 

 

#### **Roles:** 

- **Admin**: Full control over the workspace. 

- **Member**: Can edit content. 

- **Contributor**: Can add content but not edit existing ones. 

- **Viewer**: Read-only access. 

 

--- 

 

### **14. Use an App Workspace** 

 

Once you have created a workspace: 

 

1. Use it to develop and store shared reports and datasets. 

2. Collaborate with team members to create reports. 

3. Control access and manage permissions for the content. 

 

--- 

 

### **15. Publish an App** 

 

Apps are a collection of dashboards and reports packaged together for easy sharing. 

 

1. Go to the **App Workspace** in the **Power BI Service**. 

2. Click **Publish App**. 

3. Choose which content to include (reports, dashboards, etc.). 

4. Set permissions and click **Publish**. 

 

> Users can then access the app through the **Power BI Service** or install it directly from 

the app store. 

 

 

 

 

 

 

 



 

 

Unit III 
### **Other Power BI Components and Table Relationships** 

 

Power BI has multiple components designed to help users connect, transform, and visualize 

data across different devices and formats. Let’s explore how to utilize these components, 

manage relationships between tables, and effectively use Power BI on mobile devices. 

 

--- 

 

### **1. Table Relationships in Power BI** 

 

Table relationships are crucial in Power BI for combining data from multiple tables. You 

create relationships using **Primary Keys** and **Foreign Keys** that connect one table to 

another, similar to traditional database systems. 

 

#### **Creating Relationships in Power BI Desktop** 

 

1. **Load Tables**: Import multiple tables into Power BI Desktop from different sources. 

2. **Go to the Model View**: 

   - Click on the **Model** icon on the left pane (the one that looks like a table with 

connections). 

3. **Create Relationships**: 

   - Drag and drop a field from one table to another to create a relationship. 

   - Alternatively, go to the **Manage Relationships** option on the toolbar. 

4. **Set Relationship Properties**: 

   - Choose the **relationship type**: 

     - **One-to-Many**: One table has unique values; the other has repeating values. 

     - **Many-to-Many**: Both tables have repeating values. 

   - Choose **cross-filter direction**: 

     - **Single**: Filters flow in one direction only. 

     - **Both**: Filters apply in both directions. 

 

#### **Example of Table Relationships:** 

Suppose you have a `Sales` table and a `Products` table. Create a relationship using 

`ProductID` from both tables. This relationship allows you to see total sales for each product 

category. 

 

--- 

 

### **2. Power BI Mobile Apps** 

 



Power BI offers mobile applications for on-the-go access to reports and dashboards. The apps 

are available for iOS, Android, and Windows devices. 

 

#### **Get Power BI for Mobile** 

 

- Go to the app store for your platform (App Store for iOS, Google Play for Android, 

Microsoft Store for Windows). 

- Search for **Power BI**. 

- Download and install the **Power BI Mobile** app. 

- Sign in using your organizational account. 

 

#### **View Reports and Dashboards in the iPad App** 

 

1. **Launch the Power BI Mobile App**. 

2. Go to **Workspaces** or **My Workspace**. 

3. Tap on a **Dashboard** or **Report** to open. 

4. Use **pinch and zoom** gestures to navigate through visuals. 

5. Tap on visuals to drill down or explore data insights. 

 

--- 

 

### **3. Use Workspaces in the Mobile App** 

 

Workspaces in the mobile app function similarly to the desktop version, allowing you to 

access shared content. 

 

1. **Navigate to Workspaces**: 

   - Tap on the **Workspaces** icon in the mobile app. 

   - See a list of available workspaces you have access to. 

2. **View Content**: 

   - Open dashboards and reports that have been shared with you. 

   - Use the **search** function to quickly find content. 

3. **Interact with Reports and Dashboards**: 

   - Use filters, drill-downs, and slicers as you would in the desktop version. 

 

--- 

 

### **4. Sharing from Power BI Mobile** 

 

You can share reports and dashboards directly from your mobile device. 

 

1. **Open a Dashboard or Report**. 

2. Tap the **Share** icon at the top of the screen. 

3. Choose a **sharing method**: 



   - **Email**: Send a link to the dashboard/report via email. 

   - **Copy Link**: Copy a shareable link to share in messaging apps. 

4. Set permissions (View or Edit) as needed. 

 

> Note: Ensure that sharing permissions are enabled for the reports and dashboards in the 

Power BI Service. 

 

--- 

 

### **5. Use Power BI Desktop** 

 

Power BI Desktop is the primary tool for creating reports, transforming data, and building 

visualizations. 

 

#### **Install and Launch Power BI Desktop** 

 

1. **Download**: Go to the [Power BI Desktop Download 

Page](https://powerbi.microsoft.com/desktop). 

2. **Install**: Run the setup file and follow the installation instructions. 

3. **Launch**: After installation, open **Power BI Desktop**. 

 

#### **Power BI Desktop Interface Overview** 

 

1. **Home Tab**: Options for data import, transformations, and report building. 

2. **Data Tab**: Shows imported data tables. 

3. **Model Tab**: Used for creating and managing table relationships. 

4. **Report Tab**: Design and build your reports using visuals. 

 

--- 

 

### **6. Get Data in Power BI Desktop** 

 

1. **Click on "Get Data"**: 

   - Go to **Home** > **Get Data**. 

   - Choose from various data sources (Excel, CSV, Database, Online Services, etc.). 

2. **Select Data Source**: 

   - If connecting to an Excel file, choose **Excel**, browse to your file, and click 

**Open**. 

3. **Load or Transform Data**: 

   - Click **Load** to import data as-is. 

   - Click **Transform Data** to open the **Power Query Editor**. 

 

--- 

 



### **7. Reduce Data in Power BI Desktop** 

 

Reducing data helps optimize reports and ensure faster loading times. You can do this 

through filtering and limiting data. 

 

1. **Use Filters** in Power Query Editor: 

   - Open **Transform Data**. 

   - Click on the **Filter** icon on the desired column. 

   - Apply filters to include or exclude specific values. 

2. **Remove Unnecessary Columns**: 

   - Right-click on a column and select **Remove**. 

 

3. **Aggregate Data**: 

   - In the Power Query Editor, group by specific fields and create aggregate values (e.g., sum, 

average). 

 

--- 

 

### **8. Transform Data in Power BI Desktop** 

 

Power BI’s **Power Query Editor** provides a robust environment for transforming raw 

data before building reports. 

 

#### **Common Transformations** 

 

1. **Rename Columns**: 

   - Right-click on a column and choose **Rename**. 

 

2. **Change Data Types**: 

   - Click on the data type icon next to a column name (e.g., **123** for integers). 

   - Choose the appropriate data type (e.g., Text, Date, Currency). 

 

3. **Replace Values**: 

   - Right-click a column and select **Replace Values**. 

   - Specify the **Old Value** and **New Value**. 

 

4. **Split Columns**: 

   - Go to the **Transform** tab. 

   - Choose **Split Column** (e.g., by delimiter or number of characters). 

 

5. **Pivot and Unpivot Columns**: 

   - Use **Pivot Column** to summarize data. 

   - Use **Unpivot Columns** to transform rows into columns. 

 



#### **Example: Transforming Sales Data** 

Suppose you have a CSV file with the following data: 

``` 

Date, Product, Region, Sales 

01/01/2024, Laptop, North, 1500 

01/01/2024, Monitor, East, 800 

``` 

1. **Load the CSV file**. 

2. **Change Data Types**: 

   - Set `Date` to Date type and `Sales` to Currency. 

3. **Remove Unnecessary Columns**: 

   - Remove any columns that aren’t needed, such as `Region` if it’s not required. 

 

4. **Group and Aggregate**: 

   - Group by `Product` and create a **Sum** of `Sales`. 

 

### **9. Publish and Share Data** 

 

1. **After building and refining your report** in Power BI Desktop: 

   - Click on **File** > **Save As** to save your work. 

   - Click on **Publish** and select your **Workspace** in Power BI Service. 

    

2. **Share Reports** in Power BI Service: 

   - Go to your workspace in the Power BI Service. 

   - Open the report and click **Share**. 

   - Enter email addresses, set permissions, and click **Share**. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

Unit IV 
### **Power BI DAX Functions Overview** 

 

Data Analysis Expressions (DAX) is a collection of functions, operators, and constants used 

in Power BI to create powerful calculations, measures, and queries. DAX provides a robust 

set of functionalities to work with data, perform aggregations, and filter content dynamically. 

Below is a detailed overview of various DAX functions categories along with practical use 

cases. 

 

--- 

 

### **1. New DAX Functions in Power BI** 

 

Power BI frequently updates its DAX library, adding new functions that enhance analytical 

capabilities. A few recent DAX functions include: 

 

1. **CONCATENATEX()**: Joins text values from multiple rows into a single string. 

   ```DAX 

   CONCATENATEX(Sales, Sales[ProductName], ", ") 

   ``` 

   This example concatenates product names from the `Sales` table into a comma-separated 

string. 

 

2. **REMOVEFILTERS()**: Removes specific filters from a column or table. 

   ```DAX 

   CALCULATE(SUM(Sales[Amount]), REMOVEFILTERS(Sales[Region])) 

   ``` 

   This example calculates the total sales amount, removing the `Region` filter. 

 

3. **COALESCE()**: Returns the first non-blank value from a set of expressions. 

   ```DAX 

   COALESCE(Sales[Profit], 0) 

   ``` 

   This returns `Profit` if it's not blank, otherwise, it returns `0`. 

 

--- 

 

### **2. Date and Time Functions** 

 

DAX offers numerous date and time functions to handle date calculations. 

 



1. **DATE()**: Creates a date value. 

   ```DAX 

   DATE(2024, 9, 25) 

   ``` 

   Creates a date value for September 25, 2024. 

 

2. **YEAR(), MONTH(), DAY()**: Extract parts of a date. 

   ```DAX 

   YEAR(Sales[OrderDate]) 

   ``` 

   Extracts the year from the `OrderDate` column. 

 

3. **TODAY()**: Returns the current date. 

   ```DAX 

   TODAY() 

   ``` 

   This function is useful for dynamic date calculations. 

 

4. **DATEDIFF()**: Calculates the difference between two dates. 

   ```DAX 

   DATEDIFF(Sales[StartDate], Sales[EndDate], DAY) 

   ``` 

   Calculates the number of days between `StartDate` and `EndDate`. 

 

5. **EOMONTH()**: Returns the end of the month for a specified date. 

   ```DAX 

   EOMONTH(TODAY(), 1) 

   ``` 

   Returns the last day of the month, one month after the current date. 

 

--- 

 

### **3. Time Intelligence Functions** 

 

Time intelligence functions allow you to create measures that understand time-based data and 

perform complex time calculations. 

 

1. **TOTALYTD()**: Calculates year-to-date values. 

   ```DAX 

   TOTALYTD(SUM(Sales[Amount]), Sales[OrderDate]) 

   ``` 

   Computes the sum of `Sales[Amount]` from the start of the year until the given date in 

`OrderDate`. 

 



2. **PARALLELPERIOD()**: Shifts the date context forward or backward by a specified 

period. 

   ```DAX 

   CALCULATE(SUM(Sales[Amount]), PARALLELPERIOD(Sales[OrderDate], -1, 

MONTH)) 

   ``` 

   Returns the sum of `Sales[Amount]` for the same period in the previous month. 

 

3. **PREVIOUSMONTH()**: Returns a table that contains all dates from the previous 

month. 

   ```DAX 

   CALCULATE(SUM(Sales[Amount]), PREVIOUSMONTH(Sales[OrderDate])) 

   ``` 

 

4. **SAMEPERIODLASTYEAR()**: Returns the equivalent period from the previous year. 

   ```DAX 

   CALCULATE(SUM(Sales[Amount]), SAMEPERIODLASTYEAR(Sales[OrderDate])) 

   ``` 

 

--- 

 

### **4. Filter Functions** 

 

Filter functions modify the context of a calculation. 

 

1. **FILTER()**: Returns a table that is filtered by a given expression. 

   ```DAX 

   FILTER(Sales, Sales[Amount] > 1000) 

   ``` 

   This creates a table with sales records where the `Amount` is greater than 1000. 

 

2. **ALL()**: Removes all filters from a column or table. 

   ```DAX 

   CALCULATE(SUM(Sales[Amount]), ALL(Sales[Region])) 

   ``` 

   This calculates total sales across all regions. 

 

3. **KEEPFILTERS()**: Retains the existing filters on the columns. 

   ```DAX 

   CALCULATE(SUM(Sales[Amount]), KEEPFILTERS(Sales[Category] = "Electronics")) 

   ``` 

 

4. **CROSSFILTER()**: Manages relationships between two tables. 

   ```DAX 



   CALCULATE(SUM(Sales[Amount]), CROSSFILTER(Products[ProductID], 

Sales[ProductID], BOTH)) 

   ``` 

 

--- 

 

### **5. Information Functions** 

 

These functions provide information about column values. 

 

1. **ISBLANK()**: Checks if a value is blank. 

   ```DAX 

   IF(ISBLANK(Sales[Profit]), "No Profit", Sales[Profit]) 

   ``` 

 

2. **ISNUMBER()**: Checks if a value is a number. 

   ```DAX 

   IF(ISNUMBER(Sales[Discount]), "Valid Discount", "Invalid") 

   ``` 

 

3. **ISERROR()**: Checks if a value results in an error. 

   ```DAX 

   IF(ISERROR(Sales[Amount] / Sales[Quantity]), "Error", Sales[Amount] / Sales[Quantity]) 

   ``` 

 

--- 

 

### **6. Logical Functions** 

 

Logical functions allow conditional expressions. 

 

1. **IF()**: Performs conditional checks. 

   ```DAX 

   IF(Sales[Amount] > 500, "High", "Low") 

   ``` 

 

2. **SWITCH()**: Evaluates an expression against multiple values. 

   ```DAX 

   SWITCH( 

       TRUE(), 

       Sales[Amount] < 500, "Low", 

       Sales[Amount] < 1000, "Medium", 

       "High" 

   ) 



   ``` 

 

3. **AND() / OR()**: Combine multiple conditions. 

   ```DAX 

   IF(AND(Sales[Amount] > 500, Sales[Quantity] > 10), "High Value", "Regular") 

   ``` 

 

--- 

 

### **7. Math & Trig Functions** 

 

Mathematical operations in DAX include rounding, aggregation, and trigonometry. 

 

1. **SUM()**: Adds up values in a column. 

   ```DAX 

   SUM(Sales[Amount]) 

   ``` 

 

2. **ROUND()**: Rounds a number to a specified number of digits. 

   ```DAX 

   ROUND(Sales[Discount], 2) 

   ``` 

 

3. **DIVIDE()**: Divides two numbers, handling division by zero. 

   ```DAX 

   DIVIDE(Sales[Profit], Sales[Amount], 0) 

   ``` 

 

4. **MOD()**: Returns the remainder after division. 

   ```DAX 

   MOD(Sales[Quantity], 3) 

   ``` 

 

--- 

 

### **8. Parent and Child Functions** 

 

These functions help with hierarchical data. 

 

1. **PATH()**: Returns a string that represents the path of a parent-child hierarchy. 

   ```DAX 

   PATH(Employee[EmployeeID], Employee[ManagerID]) 

   ``` 

 



2. **PATHLENGTH()**: Returns the depth of the hierarchy. 

   ```DAX 

   PATHLENGTH(PATH(Employee[EmployeeID], Employee[ManagerID])) 

   ``` 

 

3. **LOOKUPVALUE()**: Retrieves a value based on a column reference. 

   ```DAX 

   LOOKUPVALUE(Products[ProductName], Products[ProductID], Sales[ProductID]) 

   ``` 

 

--- 

 

### **9. Text Functions** 

 

Text functions manipulate string data. 

 

1. **CONCATENATE()**: Joins two strings. 

   ```DAX 

   CONCATENATE(Sales[FirstName], Sales[LastName]) 

   ``` 

 

2. **LEFT(), RIGHT(), MID()**: Extract parts of a string. 

   ```DAX 

   LEFT(Sales[ProductName], 3) 

   ``` 

 

3. **FIND()**: Finds the position of a substring. 

   ```DAX 

   FIND("Laptop", Sales[ProductName]) 

   ``` 

 

4. **FORMAT()**: Formats a number or date as a string. 

   ```DAX 

   FORMAT(Sales[OrderDate], "MMMM YYYY") 

   ``` 

 

By leveraging these DAX functions, you can build complex and dynamic calculations in 

Power BI. 

 

 

 

 


